Firefox vulnerabilities get patched

Share

Yes, we all moved over to Firefox because of the security problems with Internet Explorer – and now Firefox is suffering similar "critical" security problems. But don’t worry – patches are available.

The bugs affect Mozilla Firefox 1.x and Mozilla Firefox 0.x, with users risking having their system compromised by hackers unless the updates are applied for the nine bugs. The fix is easy – update to Firefox version 1.5.0.4. After this version, automatic updates are incorporated, so you’ll already have been prompted to restart with the fixes installed.

If you haven’t, head over to the Mozilla website now.

More browsers:
DS web browser due in June
Microsoft offers beta version of IE7

Dave Walker